Apple

From Halfface
Jump to navigation Jump to search

which version of macos

sw_vers 
ProductName:		macOS
ProductVersion:		13.2.1
BuildVersion:		22D68

lots of info

system_profiler > /tmp/tmp

grant terminal full disk access

apple icon -> System Settings -> Privacy & Security -> Privacy -> Full Disk Access -> + -> terminal

Enable ssh access

sudo systemsetup -setremotelogin on

brew.sh install

https://brew.sh
/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

brew instal

brew install awscli oath-toolkit bash jq netcat saml2aws coreutils nmap htop pass sshuttle chromium

automounter

Suitable changes for automount. To let /home free.

/etc/auto_master
+auto_master            # Use directory service
/net                    -hosts          -nobrowse,hidefromfinder,nosuid
# /home                 auto_home       -nobrowse,hidefromfinder
sudo automount -v -c

Create /home link on read only filesystem

Create link with name /home pointing to /Users

echo -e "home\tUsers" | sudo tee -a /etc/synthetic.conf

Get a real bash

echo /usr/local/bin/bash | sudo tee -a /etc/shells

list and install updates

softwareupdate -l
softwareupdate -i Safari17.2.1VenturaAuto-17.2.1